Перенос Облика на другой хост

Установка нового сервера:

Настраиваем интерфейс:
– system-config-network-tui
– установил VSFTPD для доступа к файлам.
– Был закрыт iptables-ом

Не было доступа от пользователя.
– [[email protected] ~]# setsebool -P ftp_home_dir on
Please check back if ftp_home_dir values ??have changed:
[[email protected] ~]# getsebool -a | grep ftp

– Внес в Файл: /etc/sysconfig/i18n
LANG=”en_US”
SYSFONT=”cp866-8×16″

– Переносим со старого сервера папки
/usr/dlc
/usr/java
/usr/pro

– Остановил все базы а старом сервере через адимнку.
Запаковал tar-ом
Перенес на новый сервер
Развернул.

Создание юзеров и групп:

groupadd -g 200 progress
useradd -u 200 -g progress -d /usr/dlc/home -s /bin/sh -c "Progress user" progress
useradd -u 201 -o -g progress -d /usr/pro/admin/home -s /bin/sh -c "Progress Admin user" admin
useradd -u 202 -g progress -d /usr/pro/home -s /bin/sh -c dbadmin dbadmin
chown -R progress:progress /usr/dlc /usr/pro

Установка паролей:

# passwd progress 
# passwd admin
# passwd dbadmin

– Захожу под Админом. Получил:
/usr/pro/admin/home/bin/p_serv_back: line 8: /bin/proserve: No such file or diry
/usr/pro/admin/home/bin/runpro: line 3: EXPORT: command not found
/usr/pro/admin/home/bin/runpro: line 4: /bin/mpro: No such file or directory

Вывод: пошел проверять realpath

– Установил RealPath. Проблема не решилась

– Вспомнил про profile. Внес строки по Progress-у. Проблема решилась.

– захожу под Админом, вижу:
SYSTEM ERROR: Can’t attach shared memory with segment_id: 3440645 for ¦
¦ ./db/back_up ¦
¦ There is no server for database ./db/back_up. (1423)

– Вспомнил про Service. Внес.

– Понимаю что не стартует сервис. Нашел Скрипты в /etc/Init.D
сделал 2

– Стартанул: /usr/pro/admin/bin/servers start

[[email protected] bin]# /usr/pro/admin/bin/servers start
Start admin DB server
OpenEdge Release 10.2A0109 as of Tue Jun 9 14:12:29 EDT 2009
14:58:01 BROKER ** The database ./db/back_up is in use in multi-user mode. (276)
14:58:01 BROKER ** This process terminated with exit code 2. (8619)
OpenEdge Release 10.2A0109 as of Tue Jun 9 14:12:29 EDT 2009

– Удалил lk файл из Админ базы.
Сервер запустился!!!

– захожу по админом – тут же выбрасывает.

Обратил внимание на Сообщения при запуске Админки:
chown: changing ownership of `db/back_up.lg’: Operation not permitted
chmod: changing permissions of `db/back_up.lg’: Operation not permitted