Обновление контроллера UniFi на Debian

Обновление UniFi controller c версии 5.0.7 до версии 5.3.11.0.

2017-02-01
Debian 7.11

apt-get update
apt-get upgrade unifi
apt-get upgrade unifi-rapid

Прошло без проблем.

Плюсы:
– Решилась проблема с Картой и размещением на ней AP.

Обновление UniFi controller c версии 3.2.5 до версии 5.0.7.

Debian 7.11
Uname: 3.2.0-4-amd64 #1 SMP Debian 3.2.81-1 x86_64 GNU/Linux
Репозитарии от производителя: https://help.ubnt.com/hc/en-us/articles/220066768-UniFi-Debian-Ubuntu-APT-howto

apt-get update
apt-get upgrade unifi

Прошло без проблем.

Вторая часть…

apt-get upgrade unifi-rapid
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  icedtea-7-jre-jamvm openjdk-7-jre openjdk-7-jre-headless openjdk-7-jre-lib zabbix-agent
The following packages will be upgraded:
  acpi-support-base apache2 apache2-doc apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common apt apt-utils at base-files bash bind9-host binutils bsd-mailx ca-certificates cpio dbus dbus-x11 debian-archive-keyring
  default-jre-headless dnsutils dosfstools dpkg e2fslibs e2fsprogs exim4 exim4-base exim4-config exim4-daemon-light file fontconfig fontconfig-config fuse gnupg gpgv grub-common grub-pc grub-pc-bin grub2-common host icedtea-6-jre-cacao
  icedtea-6-jre-jamvm isc-dhcp-client isc-dhcp-common java-common krb5-locales libapt-inst1.5 libapt-pkg4.12 libbind9-80 libc-bin libc-dev-bin libc6 libc6-dev libcomerr2 libcups2 libcurl3-gnutls libdbus-1-3 libdns88 libevent-2.0-5
  libexpat1 libflac8 libfontconfig1 libfreetype6 libfuse2 libgcrypt11 libgd2-xpm libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgif4 libgnutls26 libgpgme11 libgssapi-krb5-2 libgtk-3-0 libgtk-3-bin libgtk-3-common libicu48 libidn11
  libisc84 libisccc80 libisccfg82 libjasper1 libjbig0 libjpeg8 libk5crypto3 libkeyutils1 libkrb5-3 libkrb5support0 liblcms2-2 libldap-2.4-2 liblwres80 liblzo2-2 libmagic1 libnspr4 libnss3 libnss3-1d libpixman-1-0 libpng12-0
  libsmbclient libsqlite3-0 libss2 libssh2-1 libssl1.0.0 libtasn1-3 libwbclient0 libx11-6 libx11-data libx11-xcb1 libxapian22 libxml2 libxrender1 linux-image-3.2.0-4-amd64 linux-libc-dev locales mime-support mongodb mongodb-clients
  mongodb-dev mongodb-server multiarch-support mutt ntfs-3g ntpdate openjdk-6-jre-headless openjdk-6-jre-lib openssh-client openssh-server openssl openvpn perl perl-base perl-modules procmail python-reportbug python2.7
  python2.7-minimal reportbug rpcbind rsyslog ssl-cert tzdata tzdata-java udisks unzip wget whois
146 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
Need to get 177 MB of archives.
After this operation, 29.7 MB disk space will be freed.

GUI обновилось успешно.
Статистика где-то потерялась.
Точки все видны. Статус NEEDS UPGRADE
Решил использовать – Rolling upgrade.
Процесс начался хорошо:
Начало

Закончился плохо:
Финиш

Точки в статусе DISCONNCTED пингуются. Предполагаю что работают со старой конфигурацией.
Обновление через CONSTUM UPGRADE не выполняется.

По прибытию на место выяснилось:
Точки не отдают Wifi. Световая индикация отсутствует.
Сделали:
Отключили/включили точку на коммутаторе (POE).
Точки стали видны в Контроллере со старой конфигурацией.
Выполнили UPGRADE каждой точки индивидуально – все заработало!

Вывод: ROLLING UPDATE – не применяем более.

Обновление UniFi controller c версии 3.1.9 до версии 3.2.5.

Debian
Обновление репозитариев

apt-get update

Обновление старой UniFi или установка новой версии.

apt-get install unifi-rapid

Прошло без проблем и ошибок.